Optiscan
About Optiscan

Browser

Internet Explorer V4 and above - Link to download

Netscape 7.1 and above - Link to download

Safari 1.2 and above - Link to download

Opera 6 and above - Link to download

Firefox 1 and above - Link to download

 

Other Requirements

Adobe Acrobat Reader V6 and above - Link to download

Macromedia Flash Player V7 - Link to download

Microsoft PowerPoint Viewer (optional) - Link to download

 

 

Privacy Policy | Terms of Use | Credits | Technical Requirements | 2004 OptiScan